Club Wellcraft Forums

Vacu Flush Toilet

Discuss any Wellcraft Coastal Related Topics

Vacu Flush Toilet

Postby Capricorn » April 1st, 2013, 3:30 am

Hello gang. After 2 beautiful days on the water diving around Great Keppel Island, Queensland, Australia (Google Maps or Google Earth). I now find the vacu flush toilet won't vacuum. I set out to find the problem and cant find the location of the pump, vacuum unit or the holding tank. I have had a look at the Dometic website and think I might be able to troubleshoot the problem if I could just locate the sucker.

Anyone know where they are hiding???
Capricorn
 
Posts: 9
Joined: September 11th, 2012, 5:23 am

Re: Vacu Flush Toilet

Postby Joe290 » April 1st, 2013, 10:39 pm

It may be simply that the toilet is clogged. Turn off the water and press the flush pedal so the ball valve opens. Under the ball valve is a hole about the size of a nickel (U.S. that is). This may clog with paper or other unmentionable material poke it through and your problem any be solved
Joe290
 
Posts: 13
Joined: January 29th, 2013, 9:17 pm

Re: Vacu Flush Toilet

Postby Capricorn » April 7th, 2013, 4:34 am

Thanks Jo290.

I was really hoping someone would tell me where the holding tank/vacuum pump etc are hidden. Trying to follow the sound wasnt working for me.

I FOUND IT. It is behind the panel on the Starboard side of aft berth. A mother to get to as I had to take the aft panel off as well as the starboard panel.

Found the problem. The vacuum pump has a vacuum pressure valve which responds to the lack of vacuum (after a flush) and activates the vacuum pump. This little sucker just needed a little WD40 and some hand management to get it going again. Now working perfectly. Took me 5 minutes to fix the problem, but the whole job of removing/replacing bulkhead panels took two hours.
Capricorn
 
Posts: 9
Joined: September 11th, 2012, 5:23 am


Return to Wellcraft Coastal

  • Who is online

    Users browsing this forum: No registered users and 1 guest

cron